Download

Download LRTimelapse 4

LRTimelapse 4 will run as free evaluation version until you buy a license.

It supports Lightroom 6, 5, 4 and 3 as well as Adobe Camera Raw, Bridge and After Effects in the corresponding versions.

If you have a LRTimelapse 3 or 2 License, you need to buy an upgrade for LRTimelapse 4 or continue using the old versions, that you can download from the “Older Versions” tab.

Please check our shop for information about licensing and/or upgrading existing licenses.

All licenses bought after March, 1st, 2015, will work with LRTimelapse 4 too!

Download LRTimelapse 4.0.4 (Windows)

Please note, that LRTimelapse 4 requires Java 7 or later in Windows, you can download the latest Java from here. Please choose “Windows, offline, 64bit” if you are on a 64bit Windows.

Download LRTimelapse 4.0.4 (Mac)

Should you get an “unidentified developer” message on newer MacOS, just right click → open and confirm.
  1. If you have trouble installing, please check out the Install-Page.
  2. After installing, check out the Instructions, to learn about the new workflows.

You will find the changes to former versions in my blog.

Survey: Please tell me which Lightroom or ACR Version you are using, thank you!

Download the old LRTimelapse 3

Owners of a LRT3 or LRT2 License can of course still download the old versions.
Please note, that those old version will not run without license anymore.

Comments are closed.